Logitech QuickCam Pro 4000 on Ubuntu

From Noah.org
Revision as of 00:45, 16 April 2014 by Root (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search


Newer versions of Ubuntu

See this article: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/443278 In particular, see note 37: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/443278/comments/37

The pwc.ko driver works, but it is pretty messed up. What seems to do the trick is to remove the camera from the USB port; boot Linux; unload the pwc kernel module (if loaded automatically); plug in the camera; wait; unplug the camera; unload the pwc kernel module; then plug the camera back in again. This time it may work. If not, keep doing the 'unplug-unload' dance. Also, there is a long delay (maybe 5 seconds) before video will display, even when it does work.

modprobe -r pwc

The pwc driver source explained below is basically unbuildable on recent Linux kernels. Don't bother if you are

Ubuntu 6.10

The Logitech QuickCam Pro 4000 is a great camera, but it is hard to get working. But if you want a good webcam for a low price it's worth a little effort. Ubuntu 6.10 (Edgy) includes the pwc kernel module driver that is supposed to work with this camera.

 # uname -a
 Linux noah-kubuntu 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686 GNU/Linux

The driver is broken in this kernel. You will see only a black or gray image with xawtv or camorama. The solution is to download and install the latest driver from http://www.saillard.org.

The pwc-10.0.12-rc1 driver works with Edgy Ubuntu 6.10. INSTALL.en taken from saillard:

1) download the file pwc-10.0.12-rc1.tar.bz2 (or the last available file on the site)

   wget http://www.saillard.org/linux/pwc/files/pwc-10.0.12-rc1.tar.bz2

2) unpack the file using the command command:

   tar xjf pwc-10.0.12-rc1.tar.bz2

3) compile the module (this needs the source of your actual kernel to be installed)

   cd pwc-10.0.12-rc1
   make

4) login as root

   su

5) In case an older version of the module was already installed, use the following commands to delete that module, if not go to 6)

   find /lib/modules/`uname -r`/ -name "pwc*.ko*"
   rm <name of the file.ko>

6) Copy the new modules to the old ones

   make install

or

   cp pwc.ko <path to the folder of original pwc.ko module>
   For example: /lib/modules/`uname -r`/{misc,extra}
   depmod -a

7) Unload the old module(s) (or reboot the machine)

   rmmod pwc
   rmmod pwcx
   modprobe pwc