Qmail 64-bit

From Noah.org
Revision as of 11:05, 16 August 2008 by Root (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search


When building QmailRocks on 64-bit Linux you will see this error when you get to step 6, installing Vqadmin:

 checking build system type... Invalid configuration `x86_64-unknown-linuxoldld': machine `x86_64-unknown' not recognized
 configure: error: /bin/sh ./config.sub x86_64-unknown-linuxoldld failed

Go back to just before the step where you configure:

 ./configure --enable-cgibindir=/path/to/your/cgi-bin --enable-htmldir=/path/to/your/html/directory

Then run:

 libtoolize --force

Now start over at the configure step again.

See also: 64bit_Linux_issues